Login Issues
Incident Report for Newton
Resolved
This incident has been resolved, and we are continuing to monitor system performance closely
Posted Sep 07, 2021 - 14:30 EDT
Identified
Some Newton customers may experience issues with their account access due to network congestion. Our team is working to improve login times and system operation speed.
Posted Sep 07, 2021 - 11:32 EDT
This incident affected: General (Web App, Mobile Apps, 2FA - Account Access).