Trading engine delays
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Nov 16, 2021 - 06:45 EST
Investigating
We are currently investigating an issue with our trading engine that is affecting some currencies/trading pairs.
Posted Nov 16, 2021 - 02:14 EST
This incident affected: Trading (Trading Engine).