Solana Withdrawals
Incident Report for
Newton
Resolved
This incident has been resolved.
Posted
Feb
06
,
2024
-
13:23
EST
Investigating
Users may experience temporary delays when withdrawing on the Solana network.
Posted
Feb
06
,
2024
-
10:13
EST
This incident affected: Crypto Withdrawals (Solana - SOL).
×
Subscribe to Incident
Subscribe to updates for
Solana Withdrawals
via . You'll receive .