Crypto Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 15:36 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2024 - 14:37 EDT
Update
Crypto withdrawals have been temporarily suspended while we continue to investigate this issue. All delayed transactions will be either completed or returned to user accounts in the near future.
Posted Mar 20, 2024 - 13:28 EDT
Investigating
Users may experience delays when withdrawing cryptocurrency to an external wallet while our wallet provider investigates an issue.
Posted Mar 20, 2024 - 10:30 EDT
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).