BTC Withdrawals

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Aug 07, 2024 - 18:22 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2024 - 18:07 EDT

Investigating

BTC withdrawals have been temporarily disabled while our team works to resolve an issue with our wallet provider.
Posted Aug 07, 2024 - 18:03 EDT
This incident affected: Crypto Withdrawals (Bitcoin - BTC).