Android app temporarily unavailable in Google Play Store

Incident Report for Newton

Update

We are continuing to monitor for any further issues.
Posted Apr 25, 2026 - 23:07 EDT

Monitoring

The Android app is currently unavailable to download or receive updates from the Google Play Store.

Users who already have the app installed are unaffected apart from not being able to receive updates.
Posted Apr 25, 2026 - 23:05 EDT
This incident affects: General (Mobile Apps).