A fix has been implemented and we are monitoring the results.
Posted Jun 03, 2026 - 18:03 EDT
Investigating
We are currently investigating an issue with our authentication provider where some users may see an “Access Denied” error when attempting to log in. We will provide an update as soon as more information is available.
Posted Jun 03, 2026 - 17:58 EDT
This incident affected: General (Web App, Mobile Apps).