LUNC: Funding Unavailable
Incident Report for Newton
Update
Trading has been re-enabled.
Posted Jun 02, 2022 - 13:34 EDT
Update
We are continuing to investigate this issue.
Posted May 26, 2022 - 17:18 EDT
Investigating
Trading (buying and selling) and funding are currently unavailable for LUNC
Posted May 15, 2022 - 14:26 EDT
This incident affects: Crypto Funding (LUNC).