LUNA and UST: Processing Delays
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 13, 2022 - 15:20 EDT
Identified
LUNA and UST deposits and withdrawals may have processing delays due to instability with the Terra network.
https://status.fireblocks.com/
Posted May 11, 2022 - 09:19 EDT
This incident affected: Crypto Funding (LUNC, Terra USD - UST).