Trading functionality impacted
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Oct 21, 2024 - 11:14 EDT
Identified
We have identified the root cause and are actively working on a solution. This is only impacting cancelations of limit orders.
Posted Oct 21, 2024 - 09:57 EDT
Update
We have identified that the only affected trading functionality is Limit Orders. We are continuing our investigation.
Posted Oct 21, 2024 - 09:30 EDT
Investigating
We have identified an issue with Trading functionality - Trading is impacted and we are investigating.
Posted Oct 21, 2024 - 09:15 EDT
This incident affected: Trading (Trading Engine).