Incident Affecting ETransfers
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 07:43 EDT
Monitoring
The root cause has been identified through our e-Transfer provider. We are monitoring the incident.
Posted Oct 15, 2024 - 23:22 EDT
Identified
We have identified the issue and are investigating.
Posted Oct 15, 2024 - 22:40 EDT
Update
We are continuing to investigate this issue.
Posted Oct 15, 2024 - 22:27 EDT
Investigating
We are currently aware of an issue affecting ETransfer deposits and withdrawals, we are currently investigating.
Posted Oct 15, 2024 - 22:26 EDT
This incident affected: Funding (e-Transfer Deposits), Withdrawals (e-Transfer Withdrawals), and General (Web App, Mobile Apps).