XRP Withdrawal Delays
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Sep 08, 2021 - 20:25 EDT
Update
We are continuing to investigate this issue.
Posted Sep 08, 2021 - 16:41 EDT
Investigating
Our team is investigating an issue affecting XRP deposits and withdrawals. We are working to resume regular service for XRP transactions with our wallet custodian as soon as possible.
Posted Sep 08, 2021 - 15:38 EDT