LUNA and UST Funding & Withdrawals: Degraded Service
Incident Report for Newton
Resolved
This incident has been resolved.
Posted May 09, 2022 - 19:45 EDT
Update
LUNA and UST withdrawals have been temporarily disabled due to intermittent issues with the Terra network.
Posted May 09, 2022 - 17:58 EDT
Investigating
We are currently investigating an issue reported by our wallet partner.
Posted May 09, 2022 - 16:08 EDT
This incident affected: Crypto Withdrawals (TerraUSD - UST, LUNC).