2FA via SMS - Code Delivery Failure/Delays
Incident Report for Newton
Resolved
Twilio has resolved this issue - SMS functionality is restored for 2FA.
Posted Jun 11, 2021 - 00:06 EDT
Monitoring
Twilio, our partner that support SMS for 2FA, has reported some issues with delayed SMS codes for Canadian customers. Their engineers have implemented a fix and we are currently monitoring.
Posted Jun 10, 2021 - 19:12 EDT
This incident affected: General (2FA - Account Access).