Crypto Withdrawals
Incident Report for Newton
Resolved
This incident has been resolved.
Posted Mar 20, 2024 - 19:01 EDT
Investigating
Users may experience temporary delays when withdrawing cryptocurrency while our wallet provider investigates an issue.
Posted Mar 20, 2024 - 16:28 EDT
This incident affected: Crypto Withdrawals (All Crypto Withdrawals).