Ripple (XRP) deposits/withdrawals temporarily suspended
Incident Report for Newton
Resolved
Ripple (XRP) funding and withdrawals have been re-enabled.
Posted Jun 15, 2021 - 11:01 EDT
Monitoring
We have temporarily suspended funding and withdrawals for XRP to complete a system upgrade.
Posted Jun 15, 2021 - 09:57 EDT