E-Transfer Service Outage

Incident Report for Newton

Resolved

This incident has been resolved.
Posted Dec 07, 2025 - 06:00 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 07, 2025 - 05:45 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 07, 2025 - 05:10 EST

Update

We are continuing to work on a fix for this issue.
Posted Dec 07, 2025 - 04:52 EST

Identified

We are currently experiencing an unexpected service interruption with one of our external partners. As a result e-transfer deposits and withdrawals are partially unavailable.

Thank you for your patience as we work to resolve this.
Posted Dec 07, 2025 - 04:50 EST
This incident affected: Funding (e-Transfer Deposits) and Withdrawals (e-Transfer Withdrawals).